You are not logged in.

Dear visitor, welcome to Laras Levelbase Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

  • "Eelkemama" is female

Posts: 18,364

wcf.user.option.userOption57: Customlevel

Location: Sachsen-Anhalt

  • Send private message

341

Saturday, December 18th 2010, 4:40pm

Schaue mal, ob du dort wo Plant usw. abgelegt werden, einige doppelt sind. Die musst du nach dem kopieren nämlich noch einmal umbenennen. In Extra01 usw.. Dann speichern. So mache ich es immer.
Es grüßt Elke.

Lara Croft

Professional

  • "Lara Croft" is male

Posts: 1,686

wcf.user.option.userOption56: Nop

wcf.user.option.userOption57: AC-revelations/Sims 3/F1-2010

  • Send private message

342

Saturday, December 18th 2010, 4:53pm

Ach herrje! Was man in einem einziges Jahr des nicht nutzen des LE´s doch vergisst. [:I] [hehe]

Vielen dank Elke, echt Lieb...

Gruss
Nerkan

343

Tuesday, March 8th 2011, 2:08pm

Animation von mehreren meshes in einem objekt

Hallo l.m.
ich hab Deine Anfrage auf auf tombraiderforums gelesen. Ich bin da nicht als User angemeldet, daher schreibe ich Dir auf der Levelbase.
Wenn ich Dich richtig verstanden habe willst Du ein Rollo bauen, dass nicht hochgezogen wird, sondern wo die Lamellen gekippt werden, um einen Durchblick zu ermöglichen. Du mußt zuerst in Stripix die meshes für Deine Lamellen einfügen (und zwar für jede Lamelle einzeln). Du kannst aber immer wieder das gleiche mesh verwenden (Stripix hat dabei nur die unangenehme Eigenschaft das es später identische meshes wenn sie mehrfach vorhanden sind nur einmal anzeigen - aber das spielt für die Arbeit mit dem Wadmerger keine Rolle).

Beim erstellen Deines Lamellenmeshes solltest Du darauf achten, dass es im 0-Punkt des Koordinatensystems Deines CAD Programms befindet (ist wegen der Rotationsaches nachher wichtig).

Wenn Du nun den Wadmerger startest (ich arbeite da mit 1.97 und 1.95 für das erstellen von Animationen und mit 1.98 für die Berechnung der Kollision. Bei 1.98 passieren manchmal ganz seltsame Sachen beim erstellen von Animationen mit Hilfe des Wizzard) kannst Du die Objekte mit dem Animationseditor einfügen. Bei dem was Du vor hast bietet sich ein objekt im animating-slot an. Im mesh-tree sollte sich nur noch ein mesh befinden. Dabei ist es extrem wichtig, dass es sich dabei nicht um eine Lamelle handelt, denn wir brauchen ein mesh was sich nicht dreht oder bewegt und wo wir die Lamellen dranhängen können (ich benutze da gerne einen kleinen Würfel mit Transparenztexturen aber bei Dir könnte man über einen Fensterrahmen oder ähnliches nachdenken da Du damit gleich auch noch ein static-mesh einsparen kannst.
Wenn Du den Animations Editor gestartet hast gehst Du auf den mesh tree editor (befindet sich unten rechts in der Ecke). Da hat man übrigens nicht nur die Funktion neu meshes einzufügen, sondern auch alte aus dem meshtree zu löschen. In der Liste wählst Du dann das neue mesh aus (vielleicht funktioniert es sogar, wenn Du nur ein neues mesh hast und das immer wieder neue einfügst mmmh... solltest Du vielleich ausprobieren). Zumindest solltest Du das so häufig machen, bis Du Deine Anzahl von Lamellen zusammen hast. Ich würde dann immer zuerst aus dem meshtree editor rausgehen und den Fortschritt speichern (Wadmerger ist manchmal sehr zickig und instabil).

Als nächstes gehts Du wieder in den meshtree Editor rein und und kannst die Baumstruktur editieren (das ist Das was den meisten Probleme macht und auch mich Kraft gekostet hat bevor ich es dann endlich kapiert habe. In dem Zusammenhang ist es hilfreich sich mal komplexe animierte Objekte von ihrer Baumstruktur anzuschauen). Nachdem wir die Objekte einfach nur in die Baumstruktur eingefügt haben sind diese so oranisiert wie... sagen wir mal die Knochenlieder eines Rattenschwanzes oder die Wirbel einer Schlange (Sprich, sie hängen alle hinterinander und wenn sich das erste bewegt, bewegen sich alle anderen mit. Wenn sich das mittlere bewegt, dann bewegen sich alle meshes dahinter mit, die davor aber nicht. Klar?). Wir wollen unserer Schlange aber nun einzelne Beine verpassen die sich unabhänig von einander bewegen lassen und in Deinem Fall sind das die Lamellen. Davfür mußt Du die Verkettung der Objekte lösen und sie alle einzeln an Dein mesh-0 dranhängen. Hört sich kompliziert an, ist aber ganz einfach. Du klickst Dein mesh-1 an und machst ein Häckchen in das Kästchen "push".Dann klickst Du mesh-2 an und machst dort ein Häckchen in "push" und in "pop". Das machst Du mit allen meshes bis auf dem letzten. Dort setzt Du nur ein Häckchen in "Pop". Damit ist die Baumstrukur schon fertig (nach der Logik bitte nicht fragen). Du hast damit alle meshes an mesh-0 gehängt und sie sind nun unabhänig voneinander.

Übrigens keine Panik wenn Du mal ein Häckchen falsch setzt und Deine Baumstuktur verschwindet, die ist immer noch Da und wenn Du den falschen Hacken rausnimmst, dann ist alles wieder sichtbar. Das wichtige ist: Du mußt für jedes Häckchen das entsprechende mesh erneut anklicken (echt blöd progammiert, aber wir wollen uns ja nicht beschweren denn ich könnte so etwas nicht programmieren und wir sind alle glücklich dass es Leute gibt Du uns diese tollen Tools geschenkt haben... auch wenn man manchmal graue Haare darüber bekommt).

Du kannst jetzt aus dem mesh tree editor rausgehen und solltest noch einmal speichern. Ich gehe danach immer komplett aus dem Animationseditor raus und klicke auf ein anders Objekt im Wadmerger weil die Sortierung erst dann stimmt, wenn man danach das Objekt mit dem Animations Editor erneut aufruft. Jetzt muss noch Folgendes gemacht werden, bevor Du mit der Animation anfängst. Du mußt die einzelnen Lamellen in die richtige Position zu mesh-0 bringen (sie liegen meistens noch alle an der gleichen Stelle). Das machst Du auch im Animations Editor. Unten sollte "no Animation" stehen und Du mußt den "move" button drücken. Dann bei "current mesh" dein jeweiliges mesh auswählen und die Position festlegen. Beim auswählen zickt der Wadmerger auch manchmal rum, deshalb immer schauen ob das mesh auch wirklich ausgewählt (im 3D Fenster grau markiert und mit Richtungsachsen versehen)ist. Und wenn alle Lamellen an der richtigen Position sind kannst Du endlich mit der Animierung anfangen. Kleiner Tipp noch: Da Du jede Lamelle einzeln drehen mußt bietet es sich an die Gradzahl einmal über STRG-C in die Zwischenablage zu kopieren und dann wieder über STRG-V einzufügen (bei Karl Theodor hat das auch funktioniert).

Da ich Deine Level kenne (und bewundere) denke ich, dass Dein einziges Problem die vermaledeite Baumstrukur ist. Ich häng also noch einmal eine PDF an in der ich das ganze schnell mal visualisiert habe.

Baumstruktur.pdf

Also toi toi toi und liebe Grüße vom Bergzwerg

This post has been edited 1 times, last edit by "berg_zwerg" (Mar 8th 2011, 2:30pm)


l.m.

Sage

  • "l.m." is male

Posts: 5,761

wcf.user.option.userOption56: The legend of King Arthur... und ein paar andere Projekte...

wcf.user.option.userOption57: mal dies, mal das...

Location: Dortmund

  • Send private message

344

Tuesday, March 8th 2011, 2:56pm

erstmal..
WOW. danke für deine absolut klare und verdammt einleuchtende Antwort [:D]
ich habe es durch absolutes try and error heute mittag noch geschafft.
hätte ich den post vorher gelesen hätt ich mir viel ersparen können [:D]

Du klickst Dein mesh-1 an und machst ein Häckchen in das Kästchen "push".Dann klickst Du mesh-2 an und machst dort ein Häckchen in "push" und in "pop". Das machst Du mit allen meshes bis auf dem letzten. Dort setzt Du nur ein Häckchen in "Pop". Damit ist die Baumstrukur schon fertig (nach der Logik bitte nicht fragen). Du hast damit alle meshes an mesh-0 gehängt und sie sind nun unabhänig voneinander.


es gibt dazu ein super tut von uranos (auch heute mittag erst kapiert.. nachdem ich gleichzeitig die ganze zeit rumgetestet habe ^^)
http://www.trforge.net/forum/index.php?p…d&threadID=1927
da ist auch erklärt wofür pop und push steht.

Übrigens keine Panik wenn Du mal ein Häckchen falsch setzt und Deine Baumstuktur verschwindet, die ist immer noch Da und wenn Du den falschen Hacken rausnimmst, dann ist alles wieder sichtbar. Das wichtige ist: Du mußt für jedes Häckchen das entsprechende mesh erneut anklicken (echt blöd progammiert, aber wir wollen uns ja nicht beschweren denn ich könnte so etwas nicht programmieren und wir sind alle glücklich dass es Leute gibt Du uns diese tollen Tools geschenkt haben... auch wenn man manchmal graue Haare darüber bekommt).

jap so ist es. aber es würde vieles einfacher machen, hätte wadmerger eine vernünftige fehlerroutine [:p]
so gibt man zu schnell auf, weil nicht nur das problem an sich schon kompliziert ist, sondern das Programm einem auch noch einen Strich durch
die Rechnung macht [:D] .
aber nun gut.

Das machst Du auch im Animations Editor. Unten sollte "no Animation" stehen und Du mußt den "move" button drücken. Dann bei "current mesh" dein jeweiliges mesh auswählen und die Position festlegen. Beim auswählen zickt der Wadmerger auch manchmal rum, deshalb immer schauen ob das mesh auch wirklich ausgewählt (im 3D Fenster grau markiert und mit Richtungsachsen versehen)ist.

ohja.. ich hab rausgefunden das man mit rechtsklick auch einfach sein mesh auswählen kann. scheint die sichere Variante zu sein!

Kleiner Tipp noch: Da Du jede Lamelle einzeln drehen mußt bietet es sich an die Gradzahl einmal über STRG-C in die Zwischenablage zu kopieren und dann wieder über STRG-V einzufügen (bei Karl Theodor hat das auch funktioniert).

jap, so hab ich es gemacht [:D]

und freut mich das dir meine Level gefallen [:D]
nja das problem war anfangs auch, das ich nicht wusste wie man nun einfach meshes einfügt.
dieses ständige hin und her mit strpix und wadmerger und den ewigen fehlermeldungen... dadurch verliert man
sehr schnell den überblick, und auch was nun richtig war, und was falsch ist...

l.m.

Sage

  • "l.m." is male

Posts: 5,761

wcf.user.option.userOption56: The legend of King Arthur... und ein paar andere Projekte...

wcf.user.option.userOption57: mal dies, mal das...

Location: Dortmund

  • Send private message

345

Tuesday, March 15th 2011, 8:24am

wann tritt der auf?

1. beim starten des Programmes -> Visual Basic Runtimes installieren, (gibts im Stuff oder auf trsearch)

2. während du mit dem Wadmerger arbeitest -> Dann hast du das Programm geärgert. neu starten, und überprüfen ob dein Klick der diesen Fehler verursacht war
wirklich "dau-frei" war (dau = dümmster anzunehmender user), denn das Programm verzeiht nichts, es hat keine gescheite Fehlerroutine.
Stößt wadmerger auf eine Fehlereingabe des Users, gibts keine Meldung, sondern es crasht ohne Vorwarnung.

346

Friday, March 18th 2011, 2:48pm

Ich kann keine Objekte mehr in mein Wad kopieren ohne folgende Fehlermeldung zu bekommen :


  • "Eelkemama" is female

Posts: 18,364

wcf.user.option.userOption57: Customlevel

Location: Sachsen-Anhalt

  • Send private message

347

Friday, March 18th 2011, 2:57pm

Versuche mal das Kopieren mit der Taste Shift und dem Button Copy.
Es grüßt Elke.

348

Friday, March 18th 2011, 2:58pm

Das habe ich gemacht und es hat auch geklappt allerdings stürzt die Exe jedesmal ab.

  • "Eelkemama" is female

Posts: 18,364

wcf.user.option.userOption57: Customlevel

Location: Sachsen-Anhalt

  • Send private message

349

Friday, March 18th 2011, 3:02pm

Das hatte ich noch nicht.
Wenn du schon mal die Fehlermeldung hattest, musst du erst das Programm Wadmerger verlassen und alles neu aufrufen. Oder welche EXE stürzt ab?
Es grüßt Elke.

350

Friday, March 18th 2011, 3:08pm

Die tomb4 stürzt ab .

l.m.

Sage

  • "l.m." is male

Posts: 5,761

wcf.user.option.userOption56: The legend of King Arthur... und ein paar andere Projekte...

wcf.user.option.userOption57: mal dies, mal das...

Location: Dortmund

  • Send private message

351

Friday, March 18th 2011, 4:00pm

starte den pc und wadmerger mal neu.
manchmal wirkt das wunder.

352

Friday, March 18th 2011, 4:05pm

Das Problem hab ich schon seit ein paar Tagen.

masha

Godmother of construction

  • "masha" is female

Posts: 19,779

wcf.user.option.userOption56: CTU

wcf.user.option.userOption57: dies und das

Location: Colmar

  • Send private message

353

Friday, March 18th 2011, 4:33pm

wieso tomb4.exe? ich dachte WadMerger läuft bei dir nicht. Hast du im wad irgendein CustomObjekt, der zu Abstürzen führt? nimm originalwad, tu was mittels WadMerger rein und versuche damit, wenn es geht, liegt es nicht am WM, sondern an deinem wad

SebiSake

Intermediate

  • "SebiSake" is male

Posts: 267

wcf.user.option.userOption56: Tutorial Level XD

wcf.user.option.userOption57: FFX, FFX-2, FFXII, TR4

Location: Salzburg/Austria

  • Send private message

354

Friday, May 20th 2011, 2:46pm

Guten Tag, ich hätte mal eine Frage:

Ich habe mir die Wadmerger Ver. 1.9 rev 7 heruntergeladen, jedoch funktioniert die bei mir auf Win Vista nicht... kann mir jemand verraten ob a) das die aktuellste Version ist und b) welche Version unter Vista läuft?
Runtimefehler ist es keiner, da das Programm einfach sagt "Wadmerger[...] funktioniert nicht mehr". Und mit installierten VB6Runtime funktioniert es auch nicht...

Vielen Dank im Vorhinein!

Edith: Hab mir mal die Version 1.98 Beta 3 gesaugt, und die scheint zu funktionieren. :)
Ehemaliger Nickname: "Lara 4-ever"

This post has been edited 2 times, last edit by "SebiSake" (May 20th 2011, 2:56pm)


  • "Michael_Mann" is male

Posts: 14,804

wcf.user.option.userOption56: Ich übe gerade - mal schauen was draus wird

Location: Berlin

  • Send private message

355

Saturday, May 21st 2011, 10:09pm

Du findest auf skribblerz.com eine Auflistung von Programmen die unter win vista + höher funktionieren und wie die ggfls. für win präpariert bzw. eingestellt werden müssen.
Meine VoZiDa sucht gerade meine Signatur - und solange gibt es keine... :roll:

Jörg

Professional

  • "Jörg" is male

Posts: 1,038

wcf.user.option.userOption56: Indien Level

wcf.user.option.userOption57: Nix

Location: Köln

  • Send private message

356

Friday, August 26th 2011, 9:28pm

Hallo,

kaum probiere ich wieder etwas mit dem Animation Editor rum, schon klappt es nicht.

Ich wollte einfach den Push Button aus dem Karnak Wad resettable machen. Also nach einer getimten Aktion wieder in die Ausgangsposition stellen.

Hab es wie bei dem Jump Switch aus dem Guard Wad der auch zurückstellbar ist, gemacht. Und Paolone hat ja Hinweise gegeben wie die StateID sein muss. Er nennt es Flip/Flop

Zitat:
A switch, to have flip/flop features, should have always four animations.
They, usually, will have following data:

Anim StateId NextAnim Description
-----------------------------------------------------------------
0 0 0 Still, beginning position
1 2 2 Moving from beginning pos. to ending pos.
2 1 2 Still, ending position
3 2 0 Moving from ending pos. to begning pos.

Genauso habe ich es gemacht.

Aber das Ding springt nicht zurück.

Habe eine dritte animation eingefügt, bei der der Knopf zurückspringt.

Die nächste Animation nach dem Zurückspringen ist logischerweise auch Animation 0, also die Ausgangsposition.

Wenn sich jemand damit näher auskennt, wäre ich für jede Hilfe dankbar. Man kann den Knopf dann auch auf trsearch veröffentlichen, wenn alles gehen sollte.
Jörg has attached the following file:
  • push_button.jpg (128.34 kB - 68 times downloaded - latest: Jan 29th 2013, 7:07pm)
TRNG - The only limit is your imagination

exFenris

Unregistered

357

Saturday, August 27th 2011, 6:53am

Der WADmerger ist leider nen ziemlich zickiges Programm

Jörg

Professional

  • "Jörg" is male

Posts: 1,038

wcf.user.option.userOption56: Indien Level

wcf.user.option.userOption57: Nix

Location: Köln

  • Send private message

358

Saturday, August 27th 2011, 8:57am

Ja, das weiß ich aus langen Jahren leidvoller Erfahrung.

Trotzdem müsste so ne einfache Animation möglich sein.

Ich hab die Frage jetzt mal auf tombraiderchronicles.com gestellt. Da sind auch immer gute Animationsbauer unterwegs.

Vielleicht bekomme ich Antwort.

Dann könnte man den Knopf auch auf trsearch.org veröffentlichen.
TRNG - The only limit is your imagination

Jörg

Professional

  • "Jörg" is male

Posts: 1,038

wcf.user.option.userOption56: Indien Level

wcf.user.option.userOption57: Nix

Location: Köln

  • Send private message

359

Thursday, September 1st 2011, 8:37am

Kurze Info:

Bedazzled hat es geschafft, ihn rückstellbar (resettable) zu machen.

Man muss nämlich noch die State ID verändern. Damit kenne ich mich nu gar nicht aus.

Bedazzled hat auch die Sequence Switches und den Big Push Button rückstellbar gemacht. :vneig:

Gruß
Jörg
TRNG - The only limit is your imagination

360

Friday, October 28th 2011, 2:05am

Hast du den Gegner aus einem Original TR 2 Wad oder von TrSearch? Die Gegner bei TrSearch bekommen alle notwendigen Sounds mitgeliefert . Wenn du ihn allerdings aus einem Original Wad hast musst du die Sounds noch rippen , da sonst wie du schon bemerkt hast nahezu alle anderen Game Sounds nicht funktionieren. Bzg. des Verhaltens denke ich liegt es wohl am Slot.